Credit image

¿Te gusta el diseño web? ¡Echa un vistazo a la documentación de LenguajeCSS.com!

Juego: ¿Que le ocurre a mi red?

Hacía tiempo que andaba queriendo hacer otro webgame. La verdad es que después de juegos como el webgame del MSN Messenger, el webgame de la instalación y el emezeta mindgame la participación ha sido bastante alta (cosa que agradezco mucho a todos) y esta muy dificil superarlo, pero vamos a intentarlo.

Enigma: Tenemos una red local con dos equipos, un AMD y un Pentium interconectados a través de un Router estándar con un hub interno de 10/100Mbps. Puesto que tanto el router como las tarjetas de red soportan transferencias de 100Mbps, el rendimiento de la red debería ser óptima. En cada PC tenemos instalado el sistema operativo Windows XP junto a aplicaciones diversas. Las características de cada elemento se pueden ver en el gráfico superior. Si encendemos el equipo A (AMD), todo funciona correctamente y tenemos acceso a la red (e internet), el problema ocurre cuando encendemos el otro equipo B (Pentium), que al hacerlo, el equipo A se reinicia por sí solo.

Queremos acceder a una página web concreta, con la característica de que en el Equipo B tenemos Linux como sistema (usando Konqueror) y en el equipo A, Windows (usando IE). El caso es que desde el equipo B podemos acceder a la web sin ningún problema, pero desde el equipo A no.

El objetivo del juego es descubrir cuál es la razón de lo que está ocurriendo y como solucionarlo.

¿Cuál es el motivo y como lo solucionamos?

Como siempre hasta ahora, el webgame esta basado en un hecho real. Ya conoceis las normas: preguntas de respuesta corta. Mucha suerte a todos. NOTA: Tankian y Geekdraz (asi como a los que ya les haya contado la historia) no podrán jugar puesto que ya conocen la respuesta.

Escrito por Manz, el , en webgames. Comentarios recibidos: 24.

24 comentarios de lectores
Yohnah
Yohnah
1

El equipo B se ha configurado, o su configuración estandar (si son equipos que ya vienen preparados) ya tiene asignado, para que sea el MASTER de la red netbios? O mejor dicho, tiene algo que ver que dicha máquina se le imponga para que sea el MASTER?

Manz
Manz
2

Yohnah: No, no tiene nada que ver.

lordeath
lordeath
3

Comencemos.. pudiera ser que ambas tarjetas tengan la misma MAC o bien que ambas tengan la misma IP y el windows te lo reinicie ( no es maravilloso este windows?) no es habitual... pero pudiera ser. También puede ser que el equipo B derive corriente por el cable cat5 y por eso se reinicia el A, (con el riesgo de cargarnos router y equipos...) No es la primera vez que me ocurre a mí con equipos que no tienen conectada la toma de tierra en el enchufe.

Manz
Manz
4

¡Mis felicitaciones lordeath! Un webgame resuelto en el comentario nº3. Marcará historia este tiempo-record ... El problema estaba debido a que, aunque la MAC de las tarjetas de red siempre debe ser diferente (no debe haber dos iguales), en este caso eran idénticas y el Windows reiniciaba el otro equipo al detectarlas igual... ¿? Para no dejar aquí la cosa, planteo un nuevo problema partiendo del ya resuelto (supongo que la dificultad es mucho más baja, pero he tenido que improvisarla): Queremos acceder a una página web concreta, con la característica de que en el Equipo B tenemos Linux como sistema (usando Konqueror) y en el equipo A, Windows (usando IE). El caso es que desde el equipo B podemos acceder a la web sin ningún problema, pero desde el equipo A no. ¿Cuál es el motivo y como lo solucionamos? A ver si este dura un poco más...

lordeath
lordeath
5

Jejeje, esque me ha pasado mas de una vez.. jejeje. Bueno, sobre la segunda cuestión, puede ser por muchos motivos. Partiendo de la premisa "la culpa es del usuario" puede ser que la página web use CSS3 y como no está soportado completamente en IE6, la web no se vea correctamete (o puede dar lugar a que no se vea nada dependiendo de como esté programada.)

Manz
Manz
6

Curioso tema el que comentas lordeath, es una pena que IE6 no soporte CSS completamente, con la de maravillas que se puede hacer con el. Respecto al CSS3, no es eso, aunque me alegro de que haya gente que piense en los estandares.

NoAlWin
NoAlWin
7

¿Solo pasa con IE? ¿Algún virus o similar ha estado jugeteando con el archivo HOSTS?

lordeath
lordeath
8

Bien, sigamos con las premisas de el "usuario tiene la culpa" (+ "eso te pasa por usar windows") jjeje. últimamente el tema del detector de malware y demás de windows no esta muy bien. pudiera ser que la web usara ssl con cacert.org y por eso el IE7 la bloquea como contenido inadecuado. ¿Ocurre el mismo error con otras versiones del navegador?

Clapp
Clapp
9

lordeath a la una, lordeath a las dos...

Manz
Manz
10

NoAlWin y Lordeath: El problema ocurre con cualquier navegador, no sólo el IE, y no se debe al archivo HOSTS (muy buen intento, lo pensé pero si se "chascaron" en nada lo de las MAC, hubiera sido demasiado fácil para ustedes). Finalmente, no, no es debido a web SSL con cacert.org. Por cierto, este webgame si que no lo conoce nadie, asi que puede participar cualquiera, sin las limitaciones que puse antes. Intentad hacer SÓLO una pregunta por comentario, que creo que era una de las normas.

lordeath
lordeath
11

modo cachondeo=on El windows está en modo 16 colores y los colores entre texto y fondo son muy parecidos el problema es que el texto no lo distingues del fondo modo cachondeo=off jajajja no lo tengais en cuenta.. es producto de tener poco coco + ganas de tocar las pe**tas jeje.

Tankian
Tankian
12

¿Los dos equipos estan en la misma red? Es decir, comparten la mismpa IP publica y estan en el mismo rango de IPs privadas?

Manz
Manz
13

Tankian: Tanto el equipo A como el equipo B están en la misma red y comparten la misma IP pública. El equipo A: 192.168.0.3 El equipo B: 192.168.0.2 [Modo cachondeo ON] El windows está en modo monocrómo, pero aún asi se pueden distinguir las letras...

lordeath
lordeath
14

Dile al usuario del equipo A que apague el norton internet security.. que lo unico que hace es dar por culo... :P. En serio. Yo miraría a ver si nos ha jugado una mala pasada el sistema ese de autodetección de "si hay un proxy en la red" y lo desactivaría

Manz
Manz
15

Lordeath: No existe Norton ni Murdock en el equipo A, ni tampoco está el sistema de autodetección de proxy activado.

NoAlWin
NoAlWin
16

¿Funciona alguna otra cosa por red en el equipo A? (Messenger, Thunderbird.....)

Manz
Manz
17

NoAlWin: Si, tanto el MSN Messenger como el Thunderbird funcionan correctamente.

Sergi
Sergi
18

Distintas DNS en cada configuracion de red de los equipos? Saludos

Manz
Manz
19

Sergi: Efectivamente, hay diferentes DNS pero en principio, eso no nos aclara nada ¿o si? Equipo A: Obtener DNS automáticamente Equipo B: DNS estáticas: 80.58.32.33 / 80.58.0.97 (Por ejemplo)

Sergi
Sergi
20

Puede ser una explicacion a lo que pasa... El equipo A las obtiene automaticamente y obtiene una diferentes a las del equipo B, y por lo que sea en ese momento las DNS no resuelven el dominio de la web que quiere visitar... Más de una web no puedo visitar una web y algún compañero si, y efectivamente suele usar por tener DNS diferentes....

lordeath
lordeath
21

Creo que los tiros más bien van encaminados a que el que visita la web no ha esperado la propagación de los dns de su dominio, de forma que es accesible tan solo por los que se hayan actualizado más rápidamente. ¿me equivoco? veamos la salida de un nslookup dominio.xx seguro que sale algo como: Servidor predeterminado: minerva.ttd.net Address: 194.179.1.100 > dominio.xx Servidor: minerva.ttd.net Address: 194.179.1.100 *** minerva.ttd.net no se puede encontrar dominio.xx: Non-existent domain >

Manz
Manz
22

Efectivamente, Sergi resuelve el enigma. En el caso concreto que relato ocurría la siguiente (y curiosa) situación: Como ya sabemos, nuestro Equipo A (sin Murdock) obtenía las DNS de forma automática, mientras que el Equipo B tenía las DNS de un ISP de forma estática. De esta forma, el Equipo B resolvía cualquier petición que el servidor DNS del ISP devolviera correctamente. En el caso del Equipo A, al pedir automáticamente las DNS, se las pedía al router, el cuál, tenía establecido el primer equipo de la red (192.168.0.2) como servidor DNS (posiblemente un cambio de dispositivos de hardware en la empresa). Finalmente, Equipo A estaba obteniendo las DNS del Equipo B que, tenía un demonio DNS funcionando para el exterior. Bastó con parar el servicio DNS del equipo en Linux para que funcionara correctamente. Lordeath resuelve el enigma #1. Sergi resuelve el enigma #2. Disculpas por la mala calidad del segundo enigma, ya que fue propuesto rápidamente para dejar planteado un enigma que durara un poco más. Esta visto que tendré que subir aún más el nivel Gracias a todos por jugar.

johnymepeino
johnymepeino
23

Jo... estais tan puestos que con posts como estos luego le digo a la vecina "Estuve en un congreso" :DDD

hector
hector
24

por favor tengo un problema grabe yo tengo un cyber.el messenger funciona solo en el servidor y en lo terminales de mi red no funciona.que pasa aqui

Publica tu opinión

Si lo deseas, puedes utilizar el siguiente formulario para publicar tu opinión o responder a alguna de las existentes:

Previsualización

Aquí se previsualizará su comentario. Revise que sea correcto antes de publicarlo.